[ANNOUNCE] p4d - Visualisierung und Einstellung der S-3200 via COM1

    Du hast Probleme beim Login? Schreibe uns im Forum "Probleme mit der Registrierung".

    • Das Programm ist ganz toll und ich verwende es schon recht lange. Trotzdem gibt es Dinge die man selten bis gar nicht verwendet. Ich habe z.B. noch nicht durchblickt, was man bei Eingaben Richtung Kessel hinschreiben muss, so dass das Programm nicht einen Fehler in der Eingabe meldet. Z.B. "Zurücksetzen der verbl. Heizstunden bis zur Asche entleeren Warnung". Schreib ich "Ja" oder "ja" oder "1", in jedem Fall bekomme ich eine Fehlermeldung. Bei "1" macht er es trotzdem. Auch die Sektion "Hand" führt viele Objekte auf, keines davon kann ich aber bedienen. Was mache ich falsch? Oder ist meine Installation nicht in Ordnung?
    • Moin horchi,

      dein Dashboard sieht zwar klasse aus, aber irgendwie passen die Symbole für die Heizkreise nicht.
      Was hälst du hiervon?

      Gruß
      Andreas

      PS: Ich vesruche, das Gif noch irgenwie flüssiger ablaufen zu lassen.
      Files

      Post was edited 1 time, last by konreas ().

    • horchi wrote:

      Moin Moin,

      Version 0.3.32

      Source Code

      1. - change: Code review
      2. - change: WEBIF - changed main view to dashboard
      3. - change: WEBIF - removed status display from dashboard view
      4. - added: images for PE1-25kW, PE1c, PE1, and PT4e
      Hey Jörg, habe soeben das Update gemacht. Leider schaut mein Dashboard jetzt nicht mehr so toll aus, siehe Anhang.

      Edit: das war jetzt 2 Stunden so und jetzt ist es wieder in Ordnung. Keine Ahnung was da los war.
      Files

      Post was edited 1 time, last by Babelbernd ().

    • Jörg, habe soeben das Update gemacht. Leider schaut mein Dashboard jetzt nicht mehr so toll aus, siehe Anhang.
      Edit: das war jetzt 2 Stunden so und jetzt ist es wieder in Ordnung. Keine Ahnung was da los war.
      ich vermute du verwendest Google Chrome oder einen Browser welcher sich bezüglich des Browser so ähnlich (schräg) verhält.
      Es gab bei der letzten Version eine etwas größere Änderung (Umbenennung von Styles) im CSS, das hat bei mir im FF sofort funktioniert, ich musst nicht mal Strg-r drücken, F5 hat schon genügt. Im Chrom hingegen hat das auch hier ewig gedauert bis der Browser die Daten seines Caches aktualisiert ht.
      Wie ich es verstehe soll Strg-r genau das bewirken - das aber scheinbar bei einigen Browsern nur für HTML Inhalte nicht für CSS.

      Grüße Jörg
    • New

      horchi wrote:

      Ganz ehrlich, die erscheinen mir etwas zu klobig
      Hallo Horchi,

      habe die Bilder nochmal ausgetauscht und zus. als zip-Datei hinzugefügt.

      Mit "zu klobig" meinst du bestimmt die Breite des blauen Pumpensymbols. Ich habe mich da an die Breite der blauen Fortschrittsbalken halten wollen. Ich kann die Breite aber auch mal halbieren.

      PS: ich bekomme es nicht mehr hin, die animierte Gif-Datei hochzuladen - deshalb das Zip-File.

      Gruß
      Andreas

      Update: 11:11Uhr
      Files

      Post was edited 1 time, last by konreas ().

    • New

      Nachdem ich festgestellt habe, dass die Prozessorlast im Verlaufe der Wochen stetig langsam anstieg, hab ich mir heute gedacht, ich mache mal ein reboot. Ja. War ne Scheißidee! Jetzt hab ich keinen Zugriff mehr. Im Router finde ich ihn auch nicht mehr.

      Irgendeine Chance, um das komplette Neuaufsetzen des System drum rum zu kommen?


      Grüße vom Ambergauer
      Schade, dass so viele nicht sehen, wie gut es uns in Deutschland doch geht!
    • [ANNOUNCE] p4d - Visualisierung und Einstellung der S-3200 via COM1

      New

      Ich hatte es kürzlich auch, dass mein RPi im Netzwerk nicht mehr erreichbar war. Habe dann einfach einmal hart aus-/eingeschaltet. Danach war alles wieder gut. Habe es deswegen nicht weiter analysiert.

      Meine CPU langweilt sich zw. 0 und 1% Last. Wie sieht/sah das denn bei dir aus?

      Momentan schreibe ich die Daten direkt auf die SD-Karte in die Datenbank. Zusätzlich werden sie noch per MQTT an meinen FHEM-Server übertragen. Irgendwann werde ich das nochmal umbiegen, so dass P4D und die SQL-Datenbank direkt auf meinem Hauptserver laufen. Gibt es hier Erfahrungen wie lange eine SD-Karte sowas mitmacht?

      Ansonsten würde ich auch so vorgehen, wie @horchi bereits geschrieben hat, Monitor dran und schauen woran es klemmt. Bootet er überhaupt noch oder fehlt evtl. nur die Netzwerkverbindung?

      Viele Grüße Hoppel
    • New

      horchi wrote:

      mir gefällt der ganz dünne Rand der aktuellen besser , und wenn ich das Theme auf dunkel stelle bekomme ich mit diesen um das schwarze Zahnrad mehr weißes flimmern.

      ich schließe mich aber gern der Meinung der Mehrheit an.
      Ich kann das Innere der vorhandenen Symbole gerne noch durchsichtig machen. Als ich die Symbole erstellt hatte gab es keine Einwände daher dachte ich eigentlich dass sie passen... Für Vorschläge bin ich gerne offen.
    • New

      Hallo,

      Babelbernd wrote:

      horchi wrote:

      mir gefällt der ganz dünne Rand der aktuellen besser , und wenn ich das Theme auf dunkel stelle bekomme ich mit diesen um das schwarze Zahnrad mehr weißes flimmern.

      ich schließe mich aber gern der Meinung der Mehrheit an.
      Ich kann das Innere der vorhandenen Symbole gerne noch durchsichtig machen. Als ich die Symbole erstellt hatte gab es keine Einwände daher dachte ich eigentlich dass sie passen... Für Vorschläge bin ich gerne offen.
      @horchi
      Kannst Du vll. mal eine der beiden Pumpensymbole tauschen:
      185.144.8.149/p4/
      Mich würde interessieren, wie es wirkt, wenn das innere Zahnrad in schwarz zu sehen ist.
      Dann ist nicht alles hellblau in hellblau.

      Vll macht es auch so Sinn:
      Zahnrad steht in schwarz (= kein Wasser fließt)
      Zahnrad dreht in blau (= Wasser fließt)
      Vll auch das drehende Zahnrad in dunklerem blau (= Wasser)?


      @konreas
      Ich empfinde die hellblaue Farbe in den GIFs als nicht vollflächig gefüllt.
      Wirkt irgendwie gesprenkelt.
      Ganz im Gegensatz zu dem satten hellblau in den Bögen der Temperaturskalen.


      Gruß
      meute
    • New

      Du kannst zum testen in /var/lib/p4/dashboard.php dir Zeile 179 anpassen:

      $imagePath = $value == "1.00" ? "img/icon/pump-on-1.gif" : $imagePath = "img/icon/pump-off-1.png";

      dort einfach den Pfad ändern, oder einfach das Bild in /var/lib/p4/img/icon/ tauschen.

      Grüße
      Jörg
    • New

      Hallo,

      horchi wrote:

      Du kannst zum testen in /var/lib/p4/dashboard.php dir Zeile 179 anpassen:

      $imagePath = $value == "1.00" ? "img/icon/pump-on-1.gif" : $imagePath = "img/icon/pump-off-1.png";
      Danke, aber meine Fröling-Heizung wird erst demnächst gebaut.
      Im Moment lese ich hier nur mit und bin am vorbereiten.


      Dazu gleich noch Fragen zur Raspberry Pi-Nutzung bei der Heizung.

      Wie lang sollte das Kabel (Null Modem + USB) an COM1 sein, um den Raspberry Pi sinnvoll in Kesselnähe zu befestigen?

      Ist es sinnvoll, am Raspi ein Display dranzuhängen, um im Keller immer einen visuellen Überblick zu haben?

      Oder schaut Ihr die Daten nur von der Wohnung aus an?
      Bin schon am überlegen, ein Tablet zu kaufen und das irgendwo in der Wohnung zu platzieren, um immer einen Blick drauf zu haben.
      Oder ist das übertrieben?


      Gruß
      meute

    Webutation