[ANNOUNCE] p4d - Visualisierung und Einstellung der S-3200 via COM1

    Holzheizer Forum und Holzvergaser Forum sind vereint.
    Du hast Probleme beim Login? Schreibe uns im Forum "Probleme mit der Registrierung".
    • Hallo Horchi,
      Hallo Beda22,

      könnt Ihr mal ein paar Beispiel Mail Benachrichtigungen bzw. Benachrichtigungen bei bestimmten Sensor-Werten, per Screenshot zeigen, was ihr hier so alles eingetragen habt?


      Horchi bei Status kann man nur die werte 0,1,3 eintragen oder?

      "0 / UD, 1 / UD, 3 / UD"


      siehe Screenshot

      Gruß Andy
      Dateien
      • Mail webif.PNG

        (59,04 kB, 8 mal heruntergeladen, zuletzt: )
    • Hallo Horchi,
      ich habe mal Punkte zusammen geschrieben die mir aufgefallen sind.
      Es sind ein paar Sachen die bei mir im Webif nicht funktionieren und auch zwei Punkte (Schönheitspunkte) die ich noch gerne hätte und wo ich Deine Hilfe benötige

      • Charts 3 / Senkrechte Hilfslinien / Linien-Abstand der Y-Achse / Chart 3+4: lassen sich nicht aktivieren
      • Status Gif animiert lässt sich nicht aktivieren
      • Beim Schema Setup kann nicht mehr zwischen Wert und Sensor-Bezeichnungen hin und her geschaltet werden.
      • Rahmen vom Schema der einzelnen Werte entfernen siehe Screenshot
      • Fröling Icon oder anderes Icon im Browser bei Aufruf der Webif Seite


      Vielen Dank
      Dateien
      • Unbenannt.PNG

        (69,63 kB, 14 mal heruntergeladen, zuletzt: )
    • Hat von euch jemand eine Idee warum die Heizung Status 19 "Betriebsbereit liefert:

      Quellcode

      1. Jan 14 15:08:00 raspberrypi p4d: Checking state ...
      2. Jan 14 15:08:00 raspberrypi p4d: ... got (19) 'Betriebsbereit'
      3. Jan 14 15:08:10 raspberrypi p4d: Checking state ...
      4. Jan 14 15:08:10 raspberrypi p4d: ... got (19) 'Betriebsbereit'

      Während am Display der Heizung Störung 'Aschebox voll" incl. der roten Lampe angezeigt wird?

      In den Fehlertexten steht bereits 'gegangen' was m.E. bedeutet das der Status 'Störung' wieder weg ist. 'Quitiert' ist jedoch noch nicht erschienen (was auch richtig ist).

      Quellcode

      1. 2017-01-11 07:10:30 169 gegangen Aschebox voll, bitte entleeren
      2. 2017-01-10 21:53:09 169 gekommen Aschebox voll, bitte entleeren
    • Neu

      Hört sich nach einer Definitions Geschichte an, was wird bei Fröling als Betriebsbereit definiert. Horchi dies ist auch der Grund warum ich die Meldung Aschebox voll als Fehler Mail haben wollte, bzw. diese am Schema haben wollte. Finde aber hierzu keine Möglichkeit. Hast du die Punkte von meinem vorherigen Post angesehen? Die letzten beiden Punkte sind Punkte die mir gefallen würden also nur Optik Geschichten, die andren funktionieren bei mir einfach nicht mehr, haben aber bereits funktioniert
    • Neu

      Version 0.2.14

      Änderungen:
      • make install-web üverschreibt den gewählten 'Style' nicht mehr
      • Im Stylesheet Stiel für Tabellen Button und Schema Wert getrennt
      • Fehler-Liste zeigt je Fehler nur noch eine zeile mit dem aktuellsten Status statt alle drei (gekommen/gegangen/quittiert)
      • Fehler mit animierten Status-Gif sowie Chart 3-4 behoben
      • Fehler in Schema Konfiguration (Auswahl Wert/Text) behoben
      TODO:
      • Y Trennlinien der Charts entspr. der Konfiguration setzen
        => (Edit) das geht auch, nur nicht für bereits gezeichnete Charts die werden aus dem Chache geladen!
      • Error-Mails auch bei nicht quittierten Fehlern trotz 'gutem' Status der Heizung versenden

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von horchi ()

    • Neu

      Skeidi schrieb:

      Top Dankeschön
      gerne, Danke für den Fehler-Report, mir geht beim Testen doch einiges durch die Lappen ;)

      Zu "Rahmen vom Schema der einzelnen Werte entfernen ...", ist Geschmackssache, ich habe es jetzt in den einzelnen wählbaren Styles einstellbar gemacht. Wenn man dort " --borderStyleSchemaValue: solid;" auf none stellt sind die Rahmen weg. Aber Vorsicht, die mitgelieferten Styles werden beim nächsten Update überschrieben - daher besser eigenen Style anlegen!
    • Neu

      Super hab´s schon installiert und getestet.

      was mir aufgefallen ist, dass sich folgendes nicht mehr aktivieren lässt

      1. Mail Benachrichtigung
      2. Zeitsynchronisation

      Jörg kannst du mir noch erklären wie ich ein eigenes Style erstellen kann, sodass dieses im Drop down Menü unter Setup auch extra angezeigt wird?

      Die Syles liegen ja im Ordner /var/www/html, hier hätte ich eins kopiert und mit einem anderen Namen versehen, nur dieses in das Drop Down Menü zu bekommen finde ich nicht heraus.

      Auch das mit dem Fröling Icon a im Browser bei Aufruf der Webif Seite wäre interessant zu lernen, wenn dies zu Aufwendig zu erklären ist, lassen wir es.

      Gruß Andy Tester
    • Neu

      Im Html Header ist bereits "shortcut icon" definiert das hat meinem Firefox genügt, sehe aber dass auch die Definition von "icon" nötig ist, dass habe ich nun ergänzt.
      Schau mal bitte ob es bei dir hilft.
      Als Icon referenziere ich im HTML Code immer das welches für die in den Einstellungen gewählte Heizung hinterlegt ist (P4, ...., etc.).
      Wenn es damit bei dir auch nicht geht lege mal favicon.ico im root directory der Seite an, also dort unter /var/.... wo auch die index.html liegt. Am einfachsten zum test erst mal als Link auf das png unter img/types/ deiner Heizung.

      Manche Browser unterstützen an der Stelle keine PNGs sondern nur ICOs, wenn du/ihr welche habt, eins je Typ der Heizung oder einfach eines als Standard Icon für den p4d übernehme ich es gern. Nur eines von Fröhling zu kopieren ist vermutlich Rechtlich nicht sauber sodass ich es nicht ins Git übernehmen kann ;)
    • Neu

      horchi schrieb:

      Tropaion schrieb:


      • Das erkennen vom mobilen Gerät funktioniert bei mir nicht. Es wird immer die Pc-Form angezeigt. Ich habe die aktuelle Version installiert

      • Wie viel Pixel hat dein Gerät in der Breite?
      • hast du einen Screenshot wie es aussieht, nicht das wir aneinander vorbei reden, bei der Unterschiedlichen Darstellung geht es Hauptsächlich um die Hautseite

      Ich habe es auf dem iPad laufen, also 1024 x 768 pixel.

      Im Anhang ein Bild dazu.

      Und wie habt Ihr die Port-Weiterleitung gemacht? Bei mir will es gar nicht funktionieren. TCP, TCP+UDP, UDP, nichts davon funktioniert. Nicht einmal mit einem Apache VirtualHost geht es.

      Mfg,
      Tropaion
      Dateien
      • ports.png

        (5,03 kB, 7 mal heruntergeladen, zuletzt: )
      • auflösung.jpg

        (121,57 kB, 11 mal heruntergeladen, zuletzt: )
    • Neu

      Hallo Jörg
      Mit dem Browser Icon werde ich noch testen. Was mir noch funktionell aufgefallen ist, dass man unter "Status Mail für folgende Status": die Werte nicht mehr abändern kann.
      Was auch noch in Punkt ist, kann man irgendwie die neuen Rahmungen um die einstellbaren Punkte wieder entfernen z.b sind jetzt überall gelbe Rahmen auch im Schema blau
      Dateien
      • IMG_1084.PNG

        (154,08 kB, 9 mal heruntergeladen, zuletzt: )
    • Neu

      horchi schrieb:

      Ich habe es auf dem iPad laufen, also 1024 x 768 pixel.
      das ist breit genug für die normale Darstellung, daher kein Unterschied in der Anzeige.Sieht aber etwas verrutscht aus die Anzeige , muss ich mir mal mit dem Pad ansehen!
      Super, danke!

      Kann mir keiner einen Rat zu denn Ports geben? Ich bin am verzweifeln...

      Mfg,
      Tropaion

    Webutation