[ANNOUNCE] p4d - Visualisierung und Einstellung der S-3200 via COM1

    Du hast Probleme beim Login? Schreibe uns im Forum "Probleme mit der Registrierung".
    • Die Verbindung scheint zu klappen aber danach werden die Sensoren nicht gefunden:

      May 18 05:01:48 raspberrypi p4d: MQTT: Connecting publisher to 'tcp://192.168.0.130:1883' succeeded
      May 18 05:01:48 raspberrypi p4d: MQTT: Connecting subscriber to 'tcp://192.168.0.130:1883' succeeded
      May 18 05:01:49 raspberrypi p4d: Info: Sensor 'Status' not found at home assistants MQTT, sendig config message
      May 18 05:01:49 raspberrypi p4d: -> (homeassistant/sensor/Status/config)[{"unit_of_measurement" : "","value_template" : "{{ value_json.value }}","state_topic" : "p4d2mqtt/sensor/Status/state","name" : "zst","unique_id" : "Status_p4d2mqtt"}]
      May 18 05:01:49 raspberrypi p4d: -> (p4d2mqtt/sensor/Status/state)[{ "value" : "Betriebsbereit" }]
      May 18 05:01:49 raspberrypi p4d: Info: Sensor 'Betriebsmodus' not found at home assistants MQTT, sendig config message
      May 18 05:01:49 raspberrypi p4d: -> (homeassistant/sensor/Betriebsmodus/config)[{"unit_of_measurement" : "","value_template" : "{{ value_json.value }}","state_topic" : "p4d2mqtt/sensor/Betriebsmodus/state","name" : "Betriebsmodus","unique_id" : "Betriebsmodus_p4d2mqtt"}]
      May 18 05:01:49 raspberrypi p4d: -> (p4d2mqtt/sensor/Betriebsmodus/state)[{ "value" : "Automatik" }]


      Ich habe versucht die Sensoren in der Configuration.yaml zu definieren aber das ändert nichts. Die Logs von HA sind alle sauber...
    • Ich habe HA mit Mosquitto noch einmal neu installiert und jetzt geht’s, allerdings nur wenn ich wie folgt vorgehe:
      (Hass.IO; Home Assistant 0.93.2; Mosquitto broker 4.2)
      Configuration.yaml: Nichts von MQTT reinschreiben.

      Mosquitto Broker config:

      Source Code

      1. {
      2. "logins": [],
      3. "anonymous": true,
      4. "quiet_logs": true,
      5. "customize": {
      6. "active": true,
      7. "folder": "mosquitto"
      8. },
      9. "certfile": "fullchain.pem",
      10. "keyfile": "privkey.pem"
      11. }
      Show All
      In /share/mosquitto/accesscontrollist (wird ab Mosquitto 4.1. benötigt) hinzufügen:

      Source Code

      1. user p4d_subscriber
      2. topic #
      3. user p4d_publisher
      4. topic #
      5. user homeassistant
      6. topic #
      Dann sollten die Einträge in HA auftauchen. Wenn nicht, in /config/.storage/core.config_entries prüfen ob discovery: true steht.
      Der Subscriber verursacht Connection Errors und die Werte updaten sich nicht. Da aber die Entities nun vorhanden sind, reicht der Publisher. Also in in /share/mosquitto/accesscontrollist den subscriber wieder auskommentieren:

      Source Code

      1. #user p4d_subscriber
      2. topic #
      3. user p4d_publisher
      4. topic #
      5. user homeassistant
      6. topic #
      Keine Ahnung ob irgendwas unnötig oder falsch ist aber es läuft :)
      Vielen Dank nochmal!
    • Hallo zusammen,

      auf meinem Rsapberry startet plötzlich die MariaDB nicht mehr. Der P4 Dämon ist seit einem halben Jahr ohne Probleme gelaufen.

      Im Anhang ein Screenshot der beim Aufruf von tail -f /var/log/syslog kam.

      Könnte mir da vielleicht jemand weiterhelfen meine Linux kenntnisse sind ehr bescheiden bis gar nicht vorhanden.
      Files

    Webutation